Varias veces necesitamos comparar dos valores y tomar una decisión.

A veces con que se cumpla una condición es suficiente.  A veces necesitamos que se cumplan las dos condiciones.

Recordando las tablas de lógica del secundario (Tenía razón el profesor! para algo servían!), tenemos la comparación con “Y” y con “O”.

Ambas son intuitivas: “Y” implica que ambas condiciones se cumplan.  “O”, que puede ser una u otra.

A modo de de recordatorio, estas son las tablas:

Tablas Lógicas

FUNCIÓN Y(valor_lógico 1;valor_lógico_2)

Esta función tiene solo dos argumentos (lógicos) y los compara.  Solamente devuelve VERDADERO si ambas condiciones se cumplen.

Ejemplos:

  • Y(2>1;3>2) devuelve VERDADERO
  • Y(2<1;3>2) devuelve FALSO
  • Y(2<1;3<2) devueve FALSO

FUNCIÓN O(valor_lógico 1;valor_lógico_2)

Esta función tiene solo dos argumentos (lógicos) y los compara.  Devuelve VERDADERO al menos una de las dos condiciones se cumple.

Ejemplo2:

  • O(2>1;3>2) devuelve VERDADERO
  • O(2<1;3>2) devuelve VERDADERO
  • O(2<1;3<2) devueve FALSO

Vamos a ver un ejemplo práctico.

Dada una lista de vendedores, queremos asignarle la comisión de ventas que le corresponde según dos criterios:Objetivos

  • El nivel de ventas supera el objetivo.
  • El precio promedio de las ventas supera cierto valor.

Si solo cumple uno de los objetivos, el vendedor tendrá un 5% de comisión, mientras que si supera ambos, se llevará un 15%.

Por el contrario, si no alcanza al menos uno, no se lleva comisión.

FuncionesLogicas3

Redactado en palabras:

SI las Ventas > Objetivo Y Precio> Objetivo, entonces corresponde 15%; de lo contrario, SI supera el objetivo de venta O el de precio, corresponde 5%.  SI no cumple ninguno, entonces la comisión es 0%.

Vemos que no solo tenemos las funciones Y y O, sino distintas comparaciones usando SI  (para ver una descripción de la función SI, ir acá).

Sin embargo, vemos que tenemos varios SI que dependientes entre sí.  Esto se llaman SI anidados.

Recordemos la estructura de la función SI:

SI(Prueba_logica;Valor_si_verdadero;Valor_si_falso)

En la columna D, debemos ingresar las fórmula que nos ayude a determinar la comisión que corresponda.Cuadro de ventas

Para esto, vamos a armar la armar la fórmula para la celda D7 siguiendo el esquema de arriba.

Lo primero que debemos resolver es si se cumplen las DOS condiciones (el primer cuadro azul del diagrama)

  • Y(B7>$C$1;C7>$C$2)
    • B7: Ventas del vendedor AAAAA
    • $C$1: Objetivos de ventas (referencias fijas porque no cambiapara los distintos vendedores)
    • C7: Precio promedio vendedor.
    • $C$2: Objetivos de precio.

Ya tenemos la primera parte de la función:

SI(se cumplen ambas condiciones; 15% de comisión(valor_si_verdadero); <Acá necesitamos armar la otra condición del segundo cuadrado azul del diagrama)

=SI(Y(B7>$C$1;C7>$C$2);$C$4;<Valor si falso>)  [1]

Ahora debemos armar la parte de la derecha del diagrama, cuando NO se cumplen ambas condiciones.

  • O(B7>$C$1;C7>$C$2)

Si la función da verdadero, corresponde el segundo nivel de comisión (que definimos en la celda C3).  La única forma en que la evaluación da FALSO, es si ninguna de las condiciones se cumple.  Por lo tanto, corresponde 0% de comisión.

=SI(O(B7>$C$1;C7>$C$2);$C$3;0%)   [2]

Al incluir esta última fórmula en la fórmula [1], tenemos para la celda D7:

=SI(Y(B7>$C$1;C7>$C$2);$C$4;SI(O(B7>$C$1;C7>$C$2);$C$3;0%))

 

Anuncios